[darwinbuild] First use of darwinbuild

John Cebasek johnc at cryptocard.com
Thu Jul 28 12:05:44 PDT 2005

Hi All:

So I got a little further by building the kernel (xnu) first. That caused
quite a few dependent projects to be loaded and built. So that fixes the
missing make, date, localhost problem.

But now when I try and build Kerberos, I get a few errors that I can't
figure out. The first is:

"C compiler cannot create executables" and the second is:
tes/build/util/et: No such file or directory.

To (try) and correct the first error, I did an archive and install of Tiger
and then reinstalled xCode 2.1 just incase there was a problem when I did
the update from xCode 2.0 to 2.1.

But it didn't seem to do much.

Any suggestions on to how to correct these errors?

Thanks in advance for your time.

Best Regards

John Cebasek
johnc at cryptocard.com

----- Original Message ----- 
From: John Cebasek
To: darwinbuild at opendarwin.org
Sent: Wednesday, July 27, 2005 5:16 PM
Subject: [darwinbuild] First use of darwinbuild

Hi All:

I am attempting to build Kerberos via darwinbuild (which looks to be a
really neat tool).

I followed the installation/initialization instructions as per the readme
file in the distribution (pretty much following them word for word), and
then I tried to actually build Kerberos with this command
/usr/local/bin/darwinbuild Kerberos 62.

It downloaded quite a few files and then when it actually tried to do the
make, it couldn't find make. The error is:

private/var/tmp/Kerberos/build-Kerberos-62-2.sh line 96: make command not

(It also couldn't find date, hostname, tail and cut).

Obviously I've got a simple configuration problem. Can you point me to the
error of my ways?

I'm using Mac OS X 10.4.2 and xCode 2.0

Thanks in advance for your time

John Cebasek
johnc at cryptocard.com

darwinbuild mailing list
darwinbuild at opendarwin.org

More information about the darwinbuild-dev mailing list