xorg-libX11 now depends on groff, why?

Kastus Shchuka macports at tprfct.net
Wed Oct 28 10:15:51 PDT 2009

I just noticed that xorg-libX11 was upgraded:

xorg-libX11                    1.3.1_0 < 1.3.2_0

When I tried to upgrade it, groff was pulled in.

I checked dependencies of xorg-libX11 and it was true, now groff is  
listed as a dependency:

port deps xorg-libX11
Full Name: xorg-libX11 @1.3.2
Build Dependencies:   pkgconfig, xorg-util-macros, xorg-xtrans,
                       xorg-bigreqsproto, xorg-xcmiscproto, xorg-xproto,
                       xorg-xextproto, xorg-xf86bigfontproto, xorg- 
                       xorg-kbproto, groff
Library Dependencies: xorg-libXdmcp, xorg-libXau

I wonder why a library has to depend on a typesetting package? Is it  
by mistake?

I also checked changeset 59847 (listed as Bump to 1.3.2) and found  
that groff was present in previous changeset 59718 already.

The version in 59718 is 1.3.1, the one that I had installed already  
without groff. Is that possible that port file changes without  
incrementing version number?

Sorry for too many questions, I am just confused.

Thanks, -Kastus

More information about the macports-users mailing list